Page 1 of 1

Oil Pressure Concerns #2

PostPosted: Tue Jul 07, 2020 4:45 am
by ewalls2
Hello,


Question on an Oil pressure issue. 


What are your observations on the following data below?


  COVID-19 has had us back, but we are putting the 5100 back into flight mode.


On our start up after several months sitting and a new oil change we walked the Prop 10 revolutions to encourage oil movement. Yet we experienced the  following went starting:


Oil pressure did not immediately pressure up. We stopped and inspected for Oil leaks etc.

Finally, oil pressure  came up to 55 and ran for 5 minutes , but then dropped to 40 PSI  during our ground run and systems checks. Increase RPM's and it obtained 50 PSI.


Heads got to 240 F =/- 30 F. We shut down and inspected systems and let cool for 45 minutes to 120  F   ( 95 F here Today).


After cool down we restarted to check oil PSI.  The engine would not come up to pressure ( zero on the gauge) We have a low oil pressure light >20 psi that stayed lit. We know that system is working. Thus, shut the engine down for our concern of no Oil psi.


Seems the pump did not maintain it prime and when the oil pressure was bouncing/dropping to 40 psi. This is the new Jabiru Oil plate redesign to maintain constant oil pressure.  The 5100 ran fine during the first of the year with the new oil plate and components. 


1 Blade starting but oil PSI is quite concerning. We are investigating alternate methods to check the oil pressure, but the low oil light is a very strong source. 

Additionally, our Jabiru 5100 aircraft engine has a TOCA, which is placed after the oil pressure relief valve and before the oil filter. Thus, how do I remove the TOCA when the oil filter is off, so I can check the oil pressure relief valve and add one or two washers to increase the oil pressure. (I heard that as a suggestion from Jabiru to increase the oil pressure.) Continuing, may I please obtain some information or a manual on how to remove a TOCA from a Jabiru aircraft engine and on the fix that Jabiru recommended for the oil pressure being too low.

Thank you for reading my concerns and any expertise and suggestions that are provided!

Eddie



Sent from my SM-G960U using Tapatalk